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1 Usage

This document assumes that you have already the HotSpotter software running or at least ready to run

on your computer software on your computer. For Windows and Mac users, this entails downloads

and installing the software. For Linux users, this means you have downloaded the source and built

HotSpotter.

This document’s purpose is to describe the basic steps of running HotSpotter to identify individual

animals, including opening a database (or creating a new one), importing images, selecting ROIs,

querying, and naming. The instructions are primarily focused on the Mac version of the software, but

adaptation to the Windows version or the Linux version is easy. Just know that the control key (Ctrl)

on Windows is equivalent to the command key (Cmd = ) on Mac. This guide will use the Mac

notation.

1.1 Opening the Program

When HotSpotter is first run, the program prompts the user to open a database or create a new one. In

each succeeding run, it will start by opening the previous database.

To create a new database:

File → New Database [ +N]

To open an existing database

File → Open Database [ +O]

HotSpotter can also read StripeSpotter databases by opening the StripeSpotter database’s data

directory. Previous versions of HotSpotter databases are also compatible, but the first time you use a

database from an older version you should delete the old “preferences” — see the end of Section 2 for

details.
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1.2 Importing images

In order to add one or more images to the database, there are two options. To manually select specific

images from a directory, there is the command

File → Import Images (select file(s)) [ +I]

There is also the option to import an entire directory of images directly into HotSpotter. This may be

achieved with the command

File → Import Images (select directory)

HotSpotter will copy all selected images into the current database’s directory; images that have been

added may be seen under the “Image Table’.

1.3 Defining Chips with ROIs and Orientation

Before using HotSpotter to identify an animal in an image — in other words to find other images that

show the same animal —- a region of interest (ROI) and an orientation must be assigned. (The

sub-image extracted from an ROI is called a “chip”.) The ROIs must be specified first, one for each

animal you would like to have HotSpotter identify. Each ROI should include most of the body of the

animal — anything that might be a distinguishing feature — so users should err on the side of making

the ROI too large rather than too small.

In order to specify an ROI, the Image Table should be highlighted and an image should be selected.

Next, click

Actions → Add Chip [A]

and select the ROI by clicking two points in the resulting Image View’to specify opposite corners of

the ROI bounding box.

If you would like to change the resulting ROI, you can click on it to reselect an new ROI for that chip

by using

Actions → Reselect ROI [R]

You can use remove it entirely by using

Actions → Delete Chip

The default orientation of every chip is horizontal, and this is set automatically by HotSpotter. This is

usually sufficient when taking “normal” pictures of standing animals, such as zebras or giraffes. On

the other hand, for overhead pictures of animals like frogs, specification of the orientation is crucial

for accurate recognition. The orientation is best determined by drawing an axis within the ROI of the

animal in a way that can be repeated for each animal. For frog images, the repeatable orientation is

selected along the spine, from the tip of the mouth to tip of the tail. For zebra images, the repeatable
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orientation is selected along the top of the back, from the withers to the point of the croup. Any

orientation can be used, as long as it is repeatable and can be generally applied to all members of the

species.

In order to specify an orientation other than the default (horizontal) orientation, the user must click

Actions → Reselect Orientation [O]

By clicking on two points within the Image View, the chip will be given a new orientation along the

selected orientation axis. Note that the orientation does not have to be selected perfectly each time —

pretty close will suffice — but you should be consistent with the order in which you click (for

example, with frogs, by selecting the mouth and then subsequently the tail). By reversing the order of

the clicks, you will orient the chip to be inverted compared to all other chips, which will cause

HotSpotter to fail.

1.4 Chip Properties Display (Optional)

HotSpotter uses each ROI and orientation to generate a chip. Within these chips HotSpotter computes

its hotspots — elliptical regions centered on points of interest that HotSpotter automatically detects.

Intuitively, the hotspots are loosely analogous to a part of a “fingerprint” for the chip. Two chips

having enough hotspot similarity will be matched successfully by HotSpotter. A chip can be seen by

clicking on the Chip Table and then selecting a chip.
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The hotspots’ points of interest and elliptical regions can be toggled on and off by clicking on the grey

area around a chip in the Chip View. A specific hotspot can be viewed by clicking on a point of

interest on the chip within the Chip View.

1.5 Running a Query

A Query can be run on any selected chip.

Actions → Query [Q]

This will quickly find similar chips in the database. HotSpotter will automatically rank the chips in

order of similarity and will highlight the portions of the image that it identifies as being most similar.
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In this example Query View window, there are six results, each showing a pair of images. In each pair,

the query chip is shown on top and the potentially-matching chip is shown on the bottom. Clicking on

the pair will show a highlighted display. You will also notice a score for each match. The scores tend

to vary according to species and size of the image set. Small image sets will produce greater scores as

will certain datasets, such as giraffes and Grevy’s zebras.

Once you decide, based on the query, which chips show the same animal, you may record this decision

by giving the chips the same name. This requires an understanding of the meaning of the names

within HotSpotter, as described next.

1.6 IDs, Names, and Recording Matching Results

In the Chip Table, users will see Chip ID, Name, and Image Name columns.

The Chip ID is the unique numerical index that HotSpotter applies to each chip. (Remember, there can

be more than one ROI/chip per image.) As HotSpotter does its work and chips are successfully

matched, users should assign unique names to individual animals and use the same name for all chips

in which that specific animal appears. Initially, before an image is recognized, the “Name” column

value will be specified as “ ” (four underscores). This denotes an unidentified chip - a user may

double-click on a name to edit. To view animals that match, simply go to the Name Table to view all

of the matched animals with the same name. Use of copying and pasting from one chip name to the

other makes this process less prone to typing errors.

5



2 Additional Tools and Tricks

Here is a brief discussion of are a few additional tricks and options for running HotSpotter:

• Actions -> Select Next: selects the next image in the database.

• Actions -> New Chip Property: record metadata as a series of one or more

attribute/value pairs for any user defined metadata. HotSpotter will automatically import

existing metadata from StripeSpotter databases.

• Options -> Edit Preferences: change the behavior of HotSpotter. For now, these are

not very well documented and should only be used with specific guidance from the HotSpotter

team.

• Help -> View Data Directory: Opens the current database directory.

• Help -> View Source Directory: (primarily for developer usage) Opens the

HotSpotter source directory.

• Help -> View Internal Directory: Opens the current database’s hsdb directory

• Help -> Delete Computed Directory: Removes all of HotSpotter’s internal cache.If

something looks corrupted or ROIs are being oddly drawn, the user should consider deleting the

computed directory. Running this will delete cached and other temporary data and force

HotSpotter to recompute all of its data; this can be done safely, but at the cost of higher initial

wait times — potentially much higher for large databases — as HotSpotter recomputes some

information.

• Help -> Delete Global Preferences: HotSpotter keeps a small set of preference

files in the user’s home directory. These files remember the last database opened as well as other

preferences. When updating to new versions these can sometimes cause problems. You can get

rid of this remembered information within HotSpotter. If you do this and if you previously had

special settings on particular databases, you will need to re-enter these settings. You can also

perform this action by deleting the ~/.hotspotter1 folder outside HotSpotter.

1Note that ~ denotes the user’s home folder
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3 A Bit of Troubleshooting

In the event that HotSpotter behaves unexpectedly, the first thing to try is a restarting of the program.

If the error persists, the following will fix common errors:

• Mac OSX 10.9 Mavericks — Gatekeeper

On the latest two Mac operating systems, the software may not run immediately. This error is

due to a security feature called Gatekeeper. If the app fails to run, please do the following:

1. Go to System Preferences — Click the Apple icon in the menu bar (top-left of the

screen) and select System Preferences in the drop down menu.

2. Go to Security & Privacy — It is located on the top row, entitled Personal.

3. Go to the General tab.

4. On 10.9 Mavericks, there may be a button that will allow HotSpotter to open.

"HotSpotter" was blocked from opening because it is not from an

identified developer

Simply click the button Open anyway. You may stop here, skip the remaining steps, and

continue to use HotSpotter.

5. Authenticate — If the Open anyway button did not appear, click on the lock at the

bottom-left corner of the screen and subsequently input your computer username and

password.

6. In the bottom half of the General tab, there will be the following selection:

Allow applications downloaded from:

( ) Mac App Store

(X) Mac App Store and identified developers

( ) Anywhere

Select Anywhere and subsequently select Allow From Anywhere in the drop down

warning.

7. Close the System Preferences window.

8. Install HotSpotter and run it.

9. To re-enable security after running HotSpotter once, repeat the above changes to your

preferences, except click on Mac App Store and identified developers.

• Email the Developer

If all else fails users should send an email to hotspotter.ir@gmail.com. Please include

a detailed description of the error and what was being done when it happened. Then also please

copy the text in the output window to a text file, and include this in your email.
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4 Source Code

4.1 License

HotSpotter is currently distributed under the Apache License, Version 2.0.

HotSpotter

Copyright © 2014 Jon Crall, Jason Parham, Chuck Stewart

Department of Computer Science

Rensselaer Polytechnic Institute

Licensed under the Apache License, Version 2.0 (the "License");

you may not use this file except in compliance with the License.

You may obtain a copy of the License at

http://www.apache.org/licenses/LICENSE-2.0

Unless required by applicable law or agreed to in writing, software

distributed under the License is distributed on an "AS IS" BASIS,

WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.

See the License for the specific language governing permissions and

limitations under the License.

4.2 Download

Download the source code here: https://github.com/Erotemic/hotspotter

git clone git@github.com:Erotemic/hotspotter.git

Once the source code has been downloaded the program can be run by using the command:

./main.py

4.3 Contribute

HotSpotter is an open source project. If any tech-savvy users develop a cool feature or a bug-fix and

would like to see it incorporated, send an email with the proposed patch to

hotspotter.ir@gmail.com for code review.
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